Nivo slider text doesn't appear on mobile device, and non-semantic h4 before h2?

Premium WordPress Themes Support Themes Forum Nivo slider text doesn't appear on mobile device, and non-semantic h4 before h2?

This topic contains 4 replies, has 2 voices, and was last updated by  FlyThemes 3 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5170

    maemae79
    Participant

    On our website we have just used the large and small header text on the slider, and not the paragraph underneath. My client noticed that the text doesn’t show on most mobile devices. This is the same on your demo, and I just wondered if this is deliberate… To be fair, I may have answered my own question, as it wouldn’t look very good on a small screen.

    My other question is… Why are the Nivo Slider headers laid out like this:
    <h4>Corporate is</h4>
    <h2>absolutely responsive</h2>?

    <h4>Isn’t that</h4>
    <h2>semantically incorrect?</h2>

    #5172

    FlyThemes
    Keymaster

    Hi

    Please send us your site url and the login details to support@flythemes.net so we can check the codes and resolve it.

    Thank You

    #5188

    maemae79
    Participant

    I’m not concerned about the slider text displaying on mobile devices. We prefer it as it is. But I don’t like the <h4></h4> <h2></h2>! Please change this for <h2>Corporate is</h2>
    <h3>absolutely responsive</h3>.
    I tried to do this myself by editing the header.php, as the site is live, and I have custom styling which applies to the .slide-cap class. However, it seems that when I change out the header tags, my styling is being overridden somewhere. So I’ll leave it to the experts! Thank you

    #5194

    maemae79
    Participant

    I’ve actually changed the password, as I’ve kind of given up. The website is live and has been handed over to the client. W3schools doesn’t seem to care about this particular issue, and if you cange the header tags, the text will render strangely, as I have custom css in place affecting the .slider-cap h2 and h4 classes, and as we have put a full stop/period at the end of the first ‘slide title’, I have instructed the second ‘slide-title to have {text-transform: none;}. I don’t really want my client to see oddness on his new website, so I’ll just have to cross fingers and hope that this doesn’t matter.

    I tried editing the tags in header.php which worked, then editing the css accordingly AND changing the settings in the Theme options, but I couldn’t seem to get it to work. If you could instruct me on how to make the appropriate edits, I could do it out of business hours, ensuring that the correct styling is in place.

    #5210

    FlyThemes
    Keymaster

    Hi

    We have received your email.

    Thank You

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.